
How the SitRepNet CommPlan and JS8Spotter Work
Scenario-based Examples

Scenario: You wake up in the morning, and nothing is working. No electrical power, no 
Internet, not even your battery-operated radio is picking up anything. Is it just your 
neighborhood, is it local – or something bigger? Is this a short-term outage, or something 
worse? What actually happened?

If you have backup power for your HF radio station, then JS8Spotter is a great tool to help 
you find out. It is also the tool to let others know about your situation. The SitRepNet 
CommPlan provides the framework for making the most of JS8Spotter in situations like this. It
is all about exchanging information in an efficient manner.

Let’s use this scenario to illustrate what to do next. If we can work with a worst-case scenario 
such as this, anything else is going to be easy. We’ll cover how to set up for this on pages 4 
and 5 of this paper. Be sure to download and read the JS8Spotter Manual for details on how 
to use the program, and there are some great instructional videos at 
https://kf7mix.com/js8spotter.html

There are currently two “Primary” report forms in JS8Spotter that can point to other, more specific 
reports, depending on the scenario. Here’s a quick summary of those report forms and how they point 
to more specific ones.

F!104 - @SITREP Basic Check-in: Designed as a Top Level form that points to any relevant current 
reports. 
F!308 - Open Source Information Report: open source information for news bulletins.

F!104 - @SITREP Basic Check-in
The F!104 is used in different ways at different times.

• During “routine” times when all is well, it’s a notice that says, “I’m here, and I’m OK”, while 
also serving as a practice exercise of the system.
◦ Go to Tools > MCForms-Forms, select F!104
◦ Click Load Posted Expect Form to fill in previous info and make any changes needed, or 

complete the fields as needed. Be sure to include your state and Maidenhead Grid Square.
◦ Click Post Form to Expect. This updates the Date/Time code to show that it is current.
◦ ACTIVE DISTRIBUTION: Click Tools > Expect System, then right-click on F!104, 

confirm that you have @SITREP included in Allowed Callsigns/Groups, and click on 
Send Now.

◦ If it is not already there, add @SITREP in the Send To field, and check the Send as MSG 
box. Click Send.
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◦ PASSIVE DISTRIBUTION: Other stations can request your F!104 by sending @SITREP 
E? F!104. If you have @SITREP included in Allowed Callsigns/Groups, then your 
station will reply by sending your F!104 report.

• During emergency times, F!104 is used as the primary form – the foundation that the full story
is built upon.
◦ Most of this is exactly the same as we did during “routine” times, and that’s the whole point 

of using it for routine “I’m OK” reports.
◦ Go to F!304 - Individual Situation Report, complete that report to describe your current 

situation, make sure that @SITREP is included in Allowed Callsigns/Groups, then click 
Post Form to Expect. F!304 is the SitRep detail, while F!104 is pointing to that and any 
other relevant Situation Reports.

◦ Next, go to F!104. When you have F!104 up, we’ll select the Situation Report field and 
change that to Situation Report currently active - E? F!304 for details. If 
there are other relevant reports (F!306 Power Stability Report, for example), enter those in 
Other relevant current report(s) after completing those reports and posting them to 
Expect. Click Post Form to Expect.

◦ We now have the @SITREP Basic Check-in loaded and ready to go, along with any other 
reports to give a good picture of conditions where you are right now. Since we have 
included @SITREP in Allowed Callsigns/Groups anyone who is looking for that 
information need only send @SITREP E? F!104 to receive your current SitRep and a list of 
any associated reports.

◦ You can also send your F!104 to @SITREP, and those stations will receive it, with 
JS8Spotter recording it. Click Tools > Expect System, then right-click on F!104, confirm
that you have @SITREP included in Allowed Callsigns/Groups, and click on Send Now.

F!308 - Open Source Information Report
With cyber-attacks now routine, and a standard part of current military doctrine, it’s very reasonable to 
expect that at some point. How would news and information be gathered, compiled, and distributed? 
There are already several news bulletins prepared and distributed on a weekly basis via amateur radio, 
but without the internet, where would they get their raw information? One solution is based on 
JS8Spotter and SitRepNet, and F!308 is the primary report for it.

There are several different reports that could be used here, so which one to request or to send? F!308 
provides a subject, the location, the time-frame, source reliability, the basic category, and points to 
other MCForms related to the subject. Think of it as the Table of Contents rather than the book. The 
Additional Information field will probably contain a brief description as well as the supporting 
reports.

Alternative Methods
While using the MCForms for sharing local and open source information is generally the most efficient
method, there are some cases where direct text entry is needed.  There are two basic ways to handle 
this, depending on how the information collection and distribution system is set up. Each has its 
advantages and disadvantages, depending on your situation. Note that these are not using MCForms, so
they are not displayed as reports in JS8Spotter – only as text in JS8Call.
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 JS8 is a very slow mode, so always try to keep the number of characters to a minimum.⚑

Two-Step Method
In this method, there is one Expect System item that responds with either NTR (Nothing To Report), or
with one or more Expect System items that contain the text to be sent. There will be one List item, and 
one or more Content items. For this example, we’ll create an Expect System item named INTEL that 
will be the List item. You can use anything of 6 characters or less. You may want to name it with your 
bulletin name, such as “NIB” – whatever your group decides to use.

The List Item
Expect: INTEL
Response: EDSW, EFNG
Allowed Callsigns/Groups: (as appropriate for your situation)

The Content Items (then repeat for the second report, EFNG)
Expect: EDSW
Response: EDSW THIS IS THE TEXT YOU WANT TO SEND FOR ANALYSIS AND COMPILING.
EDSW is the Date/Time code that JS8Spotter creates (Tools>Datecode Tool), and is used as a serial 
number to identify this report. You could also use any other system to identify the individual reports.

In use:
 The Collecting Station will send @SITREP E? INTEL➊
 Your station will respond with the Date/Time codes of your reports (EDSW, EFNG for this ➋

example).
 The Collecting Station will send @SITREP E? EDSW➌
 Your station will respond by sending the EDSW Expect item.➍
 This will then be repeated for the other reports (EFNG).➎

One-Step Method
This uses the same basic technique as the Two-Step Method, except that instead of a List Item that 
points to other Expect System items, all information is contained in a single Expect System item.

Expect: INTEL
Response: THIS IS THE TEXT YOU WANT TO SEND FOR ANALYSIS AND COMPILING.

In use:
 The Collecting Station will send @SITREP E? INTEL➊
 Your station will respond by sending the contents of that Expect item.➋
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Message Relays
Poor band conditions and station operating schedules can interfere with getting a message through. 
There are several options for indirectly getting a message through using JS8Call, and instructions for 
each is in the JS8Call Quick Reference for SitRepNet:

• Relaying – You select a station that both you and the receiving station, as well as a “middle 
station” can reach, then you send your message by way of the middle station. The message is 
immediately relayed, rather than being stored until requested.

• Remote Message Storage at Recipient – Think of this as storing your message in a mailbox on 
the recipient’s station. It is being received and stored directly on the recipient’s system.

• Message to Mailbox at 3rd Party – You store your message at a 3rd party station (the middle 
station), and it stays there until the recipient requests that message. The “mailbox” is on a 3rd 
Party station.

• Local Message Storage and Retrieval – Use this method if you want to save a message on your 
system until the receiving station requests it. In this case, the “mailbox” is on your system.

  Instructions for retrieving those messages are also in the ⚑ JS8Call Quick Reference for SitRepNet.

Time Synchronization without Internet or GPS
JS8Call requires that the Sending and Receiving stations have their time set to 2 seconds or less, with 
the goal of <300ms time delta. The closer you get to an exact match, the better the copy. Without the 
Internet or GPS, this will have to be done manually. The JS8Call Quick Reference for SitRepNet shows
how to do this.

If time synchronization radio stations are available, they are going to be the most accurate method, and 
should be the first option.

Time Synchronization Resources
2.500 WWV (Fort Collins, Colorado)
5.000 WWV (Fort Collins, Colorado)
7.850 CHU (Ottawa, Canada)
10.000 WWV (Fort Collins, Colorado)
15.000 WWV (Fort Collins, Colorado)
15.000 WWVH (Hawaii)
20.000 WWV (Fort Collins, Colorado)
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If Time Synchronization radio stations are not available
Getting time synchronized between two stations is one thing, but how do we get everyone using 
SitRepNet synchronized? We can’t have everyone trying to match every other individual station, so we 
need a way to get everyone using one time standard without the Internet or GPS or Time 
Synchronization radio stations. Here’s how SitRepNet handles that:

• Each day, starting with the Eastern Time Zone at 18:50 Local and moving westward, one station
will send a time synchronization signal using this format:@SITREP TIME SYNC SIGNAL, 
and repeat this continually until 18:55 Local. It is vital that only ONE station is sending this 
signal.
◦ Time is set to 18:50 to 18:55 to avoid potential interference with nets.
◦ Time zones are being used as longitudinal divisions to limit the distance between stations.

• All stations should use the Time Synchronization instructions to set their system time to match 
this signal. Follow the “Fine Tuning the Time Delta” instructions to get an exact match; 
however, do NOT click on the “Reset Time Drift” – we want to keep that same time setting.

• As we move from one time zone to the next, the Time Synchronization station will have set the 
time using the previous (TZ east of you) Time Synchronization Signal. In this way, all stations 
across the continent should now have a near-exact time match.

Which stations will send the Time Synchronization Signal? That will need to be set up on-the-fly as the
grid-down situation unfolds. A station having a Real Time Clock Module with independent power 
supply would be ideal. This will need to be coordinated among available stations as soon as the need 
arises.

What About Other Modes?
SitRepNet CommPlan covers the JS8Spotter “layer”, but the JS8 is just not a good choice for some 
types of radio traffic. Here is a very brief outline of how different modes fit into the overall 
communications needs. There are, of course, other bands that will be used, but for simplicity, we’re just
looking at the 40m band. SitRepNet stations that are also proficient in CW would serve as gateways to 
other CW operators who are not using the SitRepNet system.

Content Mode Example 40m Freq. Notes
Long-form text, general info FLMSG News bulletins, AIB 7.110 AmRRON, etc.
Event-driven, short-term net FLDIGI Impromptu net scheduled F!106 see F!106 SitRepNet See Note ➊
Long-form text, 100% accuracy FLAMP Request for medical items or info 7.110 BDN, AmRRON, etc.
Bulletins FLAMP Intel compiled via F!107 7.107 Bulletin Distribution Net
Status Reports JS8Spotter/MCForms F!104, STATUS, COND 7.078 SitRepNet
Situation Reports JS8Spotter/MCForms F!3xx and F!5xx series MCForms 7.078 SitRepNet
Brief text messages JS8Spotter Intel reports, active or passive TFC 7.078 SitRepNet
All (If digital unavailable) Voice/SSB Reports from SSB-only stations 7.238 LSB AmRRON, Multi. Freqs.

 ➊ A complete set of SitRepNet NCS macros for FLDIGI can be downloaded from the SitRepNet.com Resources page. Download now 
and have it available when needed. File name is  SitRepNet-macros.mdf
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Getting Set Up for SitRepNet

Expect System
This is the key to setting up an efficient JS8Spotter system so that others can request and retrieve 
information from your station automatically. This is what tells JS8Spotter what to Expect (what to be 
looking for), who is allowed to retrieve reports, what text to reply with, and how many times a report 
can be retrieved (enter 99 for unlimited). The asterisk (*) will reply to any individual station call-sign. 
The @Groups will reply to any requests addressed to that group. Each group or call-sign must be 
separated by a comma. For example, a station requesting the F!104 report from any @SITREP station 
on the air would send “@SITREP E? F!104”, and those stations would respond by sending that report if
their Expect system is set up as shown below.

Expect Reply Who Qty
F!104 (Your report) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!308 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99

MCF

100 102 104 105 
304 305 306 307 
308 500 502 *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99

F!307 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!100 (Your report) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!103 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!106 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!300 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!301 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!304 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!305 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!306 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!500 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!505 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
NOTE (Optional / NTR) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
WX NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!502 NTR *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99

CMDS

RIG, MCF, URL, 
COND, STATUS, 
WX, NOTE, GRID *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99

URL (see notes) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
STATUS (or NTR) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!105 (Your report) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
GRID (Your Grid Square) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
F!102 (Your report) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
RIG (Your radio) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
COND G (or Y or R) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
INTEL (Optional / NTR) *,@SITREP,@SEEN,@AMRRON,@MAGNET,@GHOSTNET 99
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Notes:
 This is just a suggested setup – a ➊ starting point – so personalize it to YOUR situation.
 For (➋ Your report), see instructions in the “Routine times” section under F!104.
 For URL, you could use your QRZ.com profile page, or SitRepNet.com, or any other page, or ➌

simply not use the URL item at all.
 Add any other reports that are currently active. Inactive reports should just respond with NTR.➍

Profiles
A Profile is a set of search terms that JS8Spotter is looking for and then notifying you when found. You can set 
up any number of Profiles by clicking on File>New Profile.

Profile: SitRepNet
This is the main Profile of search terms you will be watching for. You can use this as a starting point, but adapt it 
as needed to suit your needs. Be sure to check the Background Scan box.

@GHOSTNET F!106 F!501
@SITREP F!300 F!502
CMDS F!301 F!505
F!107 F!302 F!701
F!100 F!303 F!702
F!101 F!304 MCF
F!102 F!305 NOTE
F!103 F!306 STATUS
F!104 F!307 INTEL
F!105 F!500 (Your call-sign)

Profile: Alert
These are generic search terms that may indicate alerts. You can use this as a starting point, but adapt it as 
needed to suit your needs and your location. Be sure to check the Background Scan box.

ALERT FLASH SKYWARN
EMCOMM GNUSAFL STORM
EMERG GSTFLASH TORNADO
F! HELP WARNING
F!305 HURRICANE
FL (your state) SITREP

Other Profiles to consider adding
• Groups such as @AMRRON, @ARES, @RACES, @MAGNET, @PREPNET, @GHOSTNET, etc.
• SitRepNet Call-signs that reply when you send a MSG addressed to @SITREP
• Personal Call-signs of friends and special interest groups
• Hobby and special interest search terms
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