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1.  OVERVIEW

JS8Reporter is a Situational Awareness program, and a companion program to JS8Spotter. It reads 
MCF505 Area Assessment form data received via JS8Call / JS8Spotter and displays that data on an 
offline map of North America, and in filtered and tabulated reports, allowing emergency managers, 
radio operators, and others to visualize the operational status of infrastructure across a wide area. Area 
Assessments are produced by a decentralized network of individual radio operators, making it free of 
media or institutional bias for a very realistic assessment of conditions around the country.

JS8Reporter operates entirely offline at runtime. No internet connection is required once the program 
and its map data are installed. JS8Reporter can be used as a stand-alone program when provided with 
files exported directly from JS8Spotter; this gives emergency management professionals a powerful 
tool when supported by a local amateur radio operator.

JS8Reporter is a project of SitRepNet.

Key capabilities:
• Displays color-coded map pins showing infrastructure condition at each

reporting station's grid square location
• Tabulated summary and detail views of all received assessments
• Date filtering to focus on a specific time window
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• Circle filter to focus on a geographic area
• Time Lapse playback to visualize how conditions change over time
• ALERT detection with prominent notification
• Twelve analytical report types exportable to text files
• Export of map images and tabular data

MCF505 Form: https://sitrepnet.com/mcforms/MCF505.txt
More Information: https://sitrepnet.com/js8reporter/

2.  REQUIREMENTS AND INSTALLATION

Supported Platforms
• Raspberry Pi 4B running Raspberry Pi OS Bullseye (primary platform)
• Linux (Ubuntu, Debian, and derivatives)
• macOS
• Windows 10 / 11

Python Version
• Python 3.9 or newer is required.

First-Time Setup
• An internet connection is required for the one-time setup only. After setup the program runs 

fully offline.

1. Download the install ZIP file into your Home directory, and unzip it.
https://sitrepnet.com/js8reporter-download/JS8Reporter_vN.N.N.zip (where N.N.N is the current 
version number of JS8Reporter). The ZIP file contains the following files:

• js8reporter.py
• setup.py
• run.sh
• run.bat
• JS8Reporter-UserManual_vN.N.N.pdf (where N.N.N is the current version number)

 If installing on a Windows system, your Home directory is C:\Users\username★
We recommend that you confirm the authenticity of the file by downloading the signature file (same 
name as the install file, but with a .sig extension) using the PGP Public Key:
KN4AM – Stephen Clay McGehee – 0x7C57A3E5 
(designer and developer of JS8Reporter)
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The Public Key can be found here - https://sitrepnet.com/public-keys/

2. Change directory to js8reporter, then run the setup script:
 ➤ cd js8reporter
 Run one of the following, depending on your Operating System:➤

Pi / Linux / macOS python3 setup.py

Windows python setup.py

Setup will automatically create a virtual environment, then install required Python packages and 
download the North America shapefile map data. You may see it restart itself once - this is normal.

3. Start JS8Reporter as shown in the next section (STARTING THE PROGRAM).

4. Verify the map data installed correctly:
 Help > Map Setup (setup.py)…➤

The dialog will show "Map data status: Installed " if successful.✓
Dependencies installed by setup.py

• matplotlib (map rendering and charting)
• numpy (numerical operations)
• pyshp (shapefile map data reader)
• pillow (image export)
• python3-tk (prerequisite, included with Python on most platforms)

3.  STARTING THE PROGRAM

 Open a terminal (Pi/Linux/macOS) or Command Prompt (Windows) in the js8reporter directory, and➤
then type:
Pi / Linux / macOS python3 js8reporter.py

Windows python js8reporter.py

Or, if you have created a desktop shortcut, double-click the shortcut icon.

On startup, JS8Reporter will automatically reload the last database that was opened, if one is available.
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4.  INTERFACE LAYOUT

The JS8Reporter window is divided into four main areas:

Menu Bar: File | View | Circle | Reports | Settings | Help

Loaded Assessments Map of North America with color coded map pins
Navigation Toolbar (zoom, pan, home)

Date Filter Assessment Detail / Summary Table

Status Bar Mode

Menu Bar
All program functions are accessed through the menu bar. See the individual sections below for details 
on each menu.

Left Panel — Loaded Assessments
Lists all assessments currently loaded into the program. Each entry shows the callsign, grid square, and 
report timestamp.

Color coding in the list:
• Normal text   : Valid assessment
• Bold red      : Assessment contains an ALERT
• Gray / italic : Assessment marked as invalid (excluded from map)

Click an entry to select it and view its full detail below.
• Press the Delete key while an entry is selected to mark it as invalid (or to restore it if it is 

already invalid). Marking an assessment as invalid removes it from the map and from all 
reports, but keeps it visible in the list for reference.

Date Filter
Located below the assessment list. Allows filtering by date range. See Section 9 for full details.

Map Area
Shows a color-coded map of North America. Each reporting station is represented by a map pin at its 
grid square location.

Pin colors represent infrastructure condition:
• Green  (#28a745)  =  Score 3  –  Fully Operational
• Yellow (#ffc107)  =  Score 2  –  Degraded
• Orange (#fd7e14)  =  Score 1  –  Severely Impaired
• Red    (#dc3545)  =  Score 0  –  Destroyed
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The score displayed on each pin is determined by the Pin Color Mode setting (average of all fields, 
lowest field, category-specific, etc.).

The navigation toolbar below the map provides:
• Home    – Return to the default full-map view
• Back    – Go to previous zoom/pan view
• Forward – Go to next zoom/pan view
• Pan     – Click and drag to pan the map
• Zoom    – Draw a rectangle to zoom in

Click any map pin to select that assessment and view its detail.

Assessment Detail / Summary Table
• Displays either:

◦ The full detail of the currently selected assessment, or
◦ The summary table for all currently visible assessments (shown on startup and whenever no 

assessment is selected)

To return to the summary table after selecting an assessment, use View > Show Summary, or click an 
empty area of the assessment list.

Status Bar
• Shows the most recent program message (e.g., "Loaded 12 assessments from spotter.db").

Mode Indicator
• The blue label at the right of the status bar shows the current interaction mode (e.g., "Click map 

to set circle center").

5.  LOADING ASSESSMENT DATA

JS8Reporter can load MCF505 assessment data from two sources:

Open Assessments Database  (File > Open Assessments Database…  Ctrl+D)
• Opens a JS8Spotter SQLite database file (.db). This is the primary way to load data that has 

been received over the air by JS8Spotter.
• JS8Reporter opens the database read-only and is safe to use while JS8Spotter is actively 

running and writing to the same file.
• The database path is remembered and the database is automatically reloaded the next time 

JS8Reporter starts.

Import MCF505 File  (File > Import MCF505 File…  Ctrl+O)
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• Imports MCF505 assessments from a plain text file or a JS8Spotter CSV export file. Useful for 
loading manually prepared assessments or data exported from another system.

• Supported formats:
◦ Plain text MCF505 form (as transmitted over JS8Call)
◦ JS8Spotter CSV export

Automatic Deduplication
• When loading data, JS8Reporter automatically handles duplicates:

◦ Station + Date deduplication:
◦ If the same callsign submitted more than one assessment on the same calendar day, only the 

most recent submission for that day is shown.
• Grid square deduplication:

◦ If more than one assessment maps to the same grid square, the behavior is controlled by the 
Settings > Filters > Duplicate grid-square handling option (use most recent, or average 
scores).

6.  THE ASSESSMENT LIST

The list on the left side of the window shows all loaded assessments, sorted by report creation date 
(most recent first).

Selecting an Assessment
• Click any entry to select it. The Assessment Detail panel updates to show that assessment's full 

field-by-field detail.
◦ Click an empty area of the list to deselect and return to the Summary Table view.

Marking as Invalid / Restoring
• Select an assessment and press the Delete key.

◦ If the assessment is valid, you will be asked to confirm marking it as invalid. Invalid 
assessments are grayed out in the list and excluded from the map and all reports.

◦ If the assessment is already invalid (grayed out), you will be asked to confirm restoring it as 
valid.

• Invalid/valid status is remembered between sessions for the same database.

ALERT Records
• Assessments whose text contains the word "ALERT" are shown in bold red in the list and 

trigger the ALERT notification. See Section 12.
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7.  THE MAP

Map Pins

Each assessment with a valid grid square is shown as a color-coded pin on the map. The pin label 
shows the callsign and score.

Pin label display can be toggled in Settings > Pin Colors > "Always display Map Pin info". When 
unchecked, only the color pin is shown and you click it to see details.

Pin Color Modes  (Settings > Pin Colors)
• Lowest score across all fields

◦ Pin color reflects the single worst-scoring field in the assessment.
• Average of all fields

◦ Pin color reflects the overall average score (default).
• Average within selected category

◦ Pin color reflects the average score for one specific category.
• Lowest score within selected category

◦ Pin color reflects the worst field within one specific category.

Circle Filter Overlay
When the Circle Filter is enabled, a circle is drawn on the map showing the filter boundary. 
Assessments outside the circle are excluded from the map and reports. See Section 10.

Map Navigation
• Use the navigation toolbar below the map to zoom and pan.
• The Home button returns to the full North America view.
• When the Time Lapse is running, the Left and Right arrow keys step backward and forward 

manually (only in manual step mode).

8.  ASSESSMENT DETAIL AND SUMMARY TABLE

Summary Table
• Shown on startup and whenever no individual assessment is selected.
• Displays a grid of category averages for all currently visible assessments, with Min / Max / Avg 

columns.

To return to the summary table at any time:
• Use View > Show Summary, or

Page 8 of 19 User Manual for JS8Reporter Version 1.4.0



• Click an empty area in the assessment list.

Assessment Detail
• Shown when an assessment is selected in the list.
• Displays full information for that assessment

◦ Callsign, grid square, coordinates, state, city/county
◦ Report prepared timestamp and received timestamp
◦ Source, SNR, frequency
◦ Overall average score with color bar
◦ Per-category scores with color bars
◦ Field-by-field scores (fields 1–32)
◦ Notes, if any

Score values:
• 3  –  Fully Operational
• 2  –  Degraded
• 1  –  Severely Impaired
• 0  –  Destroyed
• X  –  Unknown / Not Applicable (excluded from averages)

9.  DATE FILTER

The Date Filter is located in the lower-left panel, below the assessment list. It restricts the map and all 
reports to assessments within a specified date range.

Date Filter Options
• No Filter
• Previous N-Days – Sets the date filter to show records from the number of previous days 

entered. This is continually updated keeping it constantly updated even if the program is kept 
running for days at a time.

• Specified Dates

Date Format
• Dates must be entered as:  YYYY/MM/DD  (e.g., 2025/03/14)
• The From and To fields use overtype mode — type digits directly over the existing date. The 

cursor skips over the "/" separators automatically.

Adjusting Dates
• With the cursor in a date field, press:
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◦ + or  =  to advance the date by one day
◦ -  to move the date back by one day

Default Range
• When the filter is first enabled, it defaults to Previous 14 Days, then saves your last-used 

setting.

Buttons
• Apply  –  Activates the filter with the current From / To dates.

10. CIRCLE FILTER

The Circle Filter restricts the map and all reports to assessments whose grid square falls within a 
specified radius of a center point.

Setting the Circle Center
• Circle > Set Circle Center…

◦ The mode indicator changes to "Click map to set circle center."
◦ Click anywhere on the map to place the center point.
◦ The circle is drawn immediately.

Configuring the Circle
• Circle > Configure Circle…

◦ Opens the Settings dialog to the Circle tab, where you can enter the center latitude, 
longitude, and radius in miles directly.

Disabling the Circle
• Circle > Disable Circle

◦ Removes the circle overlay and includes all assessments regardless of location.

Notes
• The circle is drawn as a geographic ellipse on the equal-aspect lat/lon map. It appears wider 

east-west at higher latitudes, which correctly represents equal distances in all directions.
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11. TIME LAPSE

Time Lapse animates the map through assessment dates, allowing you to
visualize how conditions have changed over time.

Starting and Stopping
• View > Time Lapse  (checkbutton — checkmark shows when running)
• A checkmark next to the menu item indicates Time Lapse is active.
• Select it again to cancel.

If no dated assessments are available, Time Lapse cannot start and the checkmark is cleared 
automatically.

Time Lapse Modes
• Set in Settings > Filters > Time Lapse Mode:

• Rolling Window (default):
◦ Shows assessments within a sliding window of N days ending on the current playback date. 

The window size is user-configurable (default: 14 days). This is the most useful mode for 
showing recent conditions as the date advances.

• Cumulative:
◦ Shows all assessments up to and including the current playback date.
◦ The map "builds up" as time advances. Assessments from the current playback date are 

highlighted.
• Snapshot:

◦ Shows only assessments from the exact current playback date.

Playback Speed
• Set in Settings > Filters > Time Lapse Delay:

◦ 0.5s    –  Fast (one date every half second)
◦ 1s      –  Normal (one date per second, default)
◦ Manual  –  Use the Left / Right arrow keys to step through dates

Time Lapse Settings
• View > Time Lapse Settings…  opens the full Settings dialog where the mode, delay, and 

rolling window size can be configured.

12. ALERT DETECTION
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JS8Reporter automatically scans incoming assessments for the word "ALERT"
in the message text.

• When an ALERT Is Detected
◦ The ALERT notification appears at the top of the window in bold red
◦ A "Cancel Alert" button appears next to the notification
◦ The assessment is displayed in bold red in the assessment list

• Canceling the Alert
◦ Click the "Cancel Alert" button to dismiss the notification.

• The ALERT record remains in the list (in bold red) for reference. It will not re-trigger the 
notification within the same session.

• Marking an Alert Record as Invalid
◦ If an ALERT record is marked as invalid using the Delete key, the notification banner is 

automatically dismissed (since the record is no longer considered active).
• Enabling / Disabling ALERT Detection

◦ Settings > Preferences… > Filters tab > Alert enabled checkbox.

13. REPORTS

The Reports menu generates analytical text reports from the currently visible assessments (respecting 
the active Date Filter and Circle Filter).

• All reports open in a viewer window with:
◦ Full scrollable text display
◦ Save to Export Folder button  (saves automatically with a timestamp)
◦ Save As… button  (choose any location)
◦ Close button

• The report header shows which filters were active when the report was generated.

Report Descriptions

Area Assessment Summary
The primary summary table showing category averages for each reporting station, with Min / Max / 
Avg columns. This is the same table shown in the Assessment Detail / Summary Table panel.

Full Detail Report
Complete field-by-field detail for every visible assessment, formatted for printing or filing.
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Score Rankings
All stations sorted from worst to best overall average score. Useful for quickly identifying the most 
severely affected areas.

Category Focus  (submenu)
Select any of the eight MCF505 categories to see all stations' field-level scores for that category only. 
Stations are sorted worst to best for that category.

Categories available:
• Water
• Sewage/Waste
• Power
• Communications
• Economy
• Transportation
• Health/Safety
• Social/Political

Alert Records
Lists only the assessments that contain an ALERT, with full detail for each. Shows "No ALERT records
found" if none are present.

Geographic Summary
Assessments grouped and subtotaled by state, sorted alphabetically.
Useful for briefing by jurisdiction.

Critical Infrastructure
Lists every infrastructure field (1–32) that has been scored 0 (Destroyed) or 1 (Severely Impaired) by 
any station. Sorted by field number, showing which stations reported each critical condition.

Trend Analysis
Shows only stations that submitted assessments on more than one date, with scores for each date and an
arrow (↑ / ↓ / →) indicating the direction of change. Useful for tracking whether conditions are 
improving or deteriorating.

Infrastructure Heat Map
For each category, shows how many field scores fall at each level (0 / 1 / 2 / 3 / N/A), with percentages.
Gives a quick overview of the overall distribution of conditions.

Data Quality / Coverage
Lists each station with the number of fields reported, the completion percentage, and the age of the 
assessment in days. Useful for identifying incomplete or outdated reports.

Worst Conditions
Ranks stations by their single worst category average score (lowest first). Highlights where the most 
severe problems are concentrated.
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Network Coverage
Lists all reporting grid squares with their latitude/longitude coordinates and the date of their most 
recent assessment. Sorted north-to-south, west-to-east. Useful for mapping network coverage.

14. EXPORTING DATA

Save Text Report  (File > Save Text Report…  Ctrl+S)
• Saves a combined text file containing the Area Assessment Summary table followed by the full 

detail for every visible assessment.

Export Data (File > Export Data…  Ctrl+T)
• Exports all visible assessments as a CSV or TSV file with one row per assessment. Columns 

include callsign, grid, state, timestamps, all category averages, and all 32 individual field 
scores.

• The format (CSV or TSV) is set in Settings > Export.

Export Map Image  (File > Export Map Image…  Ctrl+E)
• Saves the current map view as an image file.
• Supported formats: PNG (default), JPEG, SVG.
• The format is set in Settings > Export.

Export Folder
• Report viewer windows include a "Save to Export Folder" button that saves the report 

automatically to the designated export folder with a timestamp-based filename (no dialog 
required).

• The default export folder is:   <program folder>/data/exports/
• A custom export folder can be set in Settings > Export > Default export folder.

15. SETTINGS

Open via Settings > Preferences…  or  Ctrl+,

Pin Colors Tab
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• Pin color mode:
• Controls what score drives the color of each map pin.
• Options:

◦ Lowest all fields
◦ Average all fields (default)
◦ Average in category
◦ Lowest in category.

Category:
The category used when a category-specific pin color mode is selected.

Rounding for averages:
• How averaged scores are rounded to a whole-number color level.
• Options: Standard rounding (default), Always round up, Always round down.

Map pin labels:
• When checked, each pin shows the callsign and score.
• When unchecked, only the color pin is shown (click to see details).

Filters Tab
• Duplicate grid-square handling:

◦ When two assessments share the same grid square, use only the most recent (default) or 
average the scores.

Category display filter:
• Limit the map and reports to selected categories only.
• Leave all checked (default) to include all categories.

Time Lapse mode:
• Rolling Window (default), Cumulative, or Snapshot. See Section 11.

Rolling window days:
• Number of days in the rolling window (default: 14).

Time Lapse delay:
• Playback speed: 0.5s, 1s, or Manual.

Alert enabled:
• Enable or disable ALERT detection.

Circle Tab
• Circle center latitude and longitude, and radius in miles. These can also be set by clicking on the

map (Circle > Set Circle Center…) or via Circle > Configure Circle….

Export Tab
• Map image format:  PNG (default), JPEG, SVG.
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Tabular data export format:  CSV (default) or TSV.

Default export folder:
• Folder used by "Save to Export Folder" in report windows.

◦ Leave blank to use the default  data/exports/  folder.
◦ Click Browse… to select a folder.

Auto-Update Tab
• Check for updates on startup
• When enabled, JS8Reporter checks SitRepNet.com for a newer release at startup (requires 

internet). Offline operation is never affected.
• Update operation is done manually – no changes are made without user action.

Version check URL:
• A .JSON file on the SitRepNet.com site is used for version checks.
• Leave the URL field blank to disable.

16. KEYBOARD SHORTCUTS

Delete Key - Mark selected assessment as invalid / restore if invalid

+ or = (in date field) Advance date by one day
- (in date field) Move date back by one day

Left (Time Lapse, manual mode) Step back one date
Right (Time Lapse, manual mode) Step forward one date

17. TROUBLESHOOTING

Map does not display / shows "matplotlib not installed"
• Run the setup script to install required packages:

◦ cd /home/<username>/js8reporter
◦ bash setup.sh
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◦ Then restart JS8Reporter.

Map displays but shows no country/state borders
• The shapefile map data is missing. Run:

◦ bash setup.sh
◦ Check Help > Map Setup (setup.sh)… to verify installation status.

No assessments loaded from the database
• Use Help > DB Diagnostic… to inspect the database. JS8Reporter looks for rows in the "forms"

table with typeid containing "505". Verify that JS8Spotter has received and stored at least one 
MCF505 form.

• Common causes:
◦ The database file selected is not a JS8Spotter database
◦ No MCF505 forms have been received yet
◦ The forms were stored under an unexpected typeid value (the diagnostic will show what 

typeids are present)

Map pins appear but in the wrong location
• The grid square field in the assessment may contain an invalid or unusual grid locator. Select 

the assessment and check the Grid field in the detail panel.

Date filter is not showing expected assessments
• Verify the From and To dates are entered correctly in YYYY/MM/DD format. Check that the 

Enable checkbox is checked and Apply was pressed.
• Also check whether the assessment's date falls in the filter range. The filter uses the received 

date if available, otherwise the report prepared date.

Time Lapse starts but the map does not change
• If only one unique date is present in the visible assessments, Time Lapse has nothing to step 

through. Try disabling the Date Filter or expanding the date range.

Auto-update check fails silently
• The update check runs in the background and fails silently if the network is unavailable. This is 

by design — offline operation is never affected.
• To disable the check entirely: Settings > Preferences > Auto-Update >

◦ uncheck "Check for updates on startup".

18. APPENDIX
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File Formats for Importing

Format 1: Plain Text MCF505 (over-the-air / JS8Call)

A plain text file (.txt or any extension). May contain multiple records — the parser splits on each F!505
marker.

Message structure:
F!505 <scores> ST[XX] GR[XXXX] CT[text] #XXXX

Field Required Description

F!505 Yes Form type marker (spacing and ! are flexible)

<scores> Yes Exactly 32 characters: digits 0–3 or X (unknown/N/A)

ST[XX] No Two-letter state abbreviation

GR[XXXX] No Maidenhead grid square (4 or 6 characters)

CT[text] No City/county name (up to 60 characters)

#XXXX No 4-character datecode encoding prepared time (UTC)

Score values:
• 3 = Good/Functional
• 2 = Degraded
• 1 = Minimal
• 0 = None/Destroyed
• X = Unknown/N/A

Datecode format (#MDHM):
• M — Month: A=Jan … L=Dec
• D — Day: A=1 … Z=26, 0=27 … 4=31
• H — Hour (UTC): A=0 … X=23
• M — Minute: A=0, B=2 … Z=50, 0=52 … 3=58 (2-minute resolution)

Checksums in {HEX} or [CRC:...] notation are stripped and ignored.

Sample
F!505 32100X3210023210032100321003 ST[TX] GR[EM10] CT[Travis County] #CEK0
F!505 2X3210032100X21003210032100 ST[OK] GR[EM25ab] CT[Oklahoma City] #CFK2

Format 2: JS8Spotter CSV Export

A comma-separated values file (.csv). Detected either by file extension or by the presence of commas 
and newlines. Column names are case-insensitive.
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Required column (one of):
Accepted names Contains

msgtxt, message, msg, text, body, data The full MCF505 message text (must contain
F!505 and a 32-char score string)

Optional columns
Accepted names Contains

fromcall, callsign, call, from, de Originating station callsign

timesig, timestamp, time, datetime, lm Prepared time — datecode (#XXXX) or parseable 
datetime string

Any additional columns are ignored.

Sample
fromcall,msgtxt,timesig
W5ABC,F!505 32100X3210023210032100321003 ST[TX] GR[EM10] CT[Travis County],#CEK0
KD5XYZ,F!505 2X3210032100X21003210032100 ST[OK] GR[EM25ab] CT[Oklahoma City],#CFK2
N5QRP,F!505 33322X1100332211003322110033 ST[NM] GR[DM65] CT[Bernalillo County],#CFM4

Note: In this sample, the first line is a header that defines the data records.

19. KNOWN ISSUES

  If a report shows a future date, this indicates the sending station's system clock was incorrect when ①
the form was prepared. The assessment scores remain valid. Future-dated reports can be excluded using
the date filter if needed.

End of JS8Reporter User Manual
JS8Reporter is designed and developed by Stephen Clay McGehee, KN4AM

Coding done using Claude Code AI
See SitRepNet.com for more information.

Use Contact form at SitRepNet.com for suggestions and bug reports.

                    ★ ★ ★ ★ ★
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